[MSEide-MSEgui-talk] Graphical RAD IDE in FPC

classic Classic list List threaded Threaded
1 message Options
mse
Reply | Threaded
Open this post in threaded view
|

[MSEide-MSEgui-talk] Graphical RAD IDE in FPC

mse
Administrator
This is a continuation of
https://www.mail-archive.com/fpc-devel%40lists.freepascal.org/msg36591.html

On Monday 17 September 2018 13:25:07 Alexander via fpc-devel wrote:
> Hi Martin,
>
> 1. On my computer with free drivers **working all soft** exclude MSE.
> 2. Non free dirivers is not drivers. Not needed.

As I already wrote I could not find the reason of the misbehavior of MSEgui
with opensource EXA-Pixmaps drivers although I spent many days with the
problem. If you find a bug in MSEgui it will be fixed as soon as possible.

> 3. https://bugs.freedesktop.org/show_bug.cgi?id=69543 developers dont known
> Pascal and MSE :)
> 4. May be problem MSE on this drivers from **network**
> and **time delay** issues ? On nonfree drivers delays minimized and MSE
> have time for display img ? Incorrect architecture for xorg ?
>
I don't think so, the problem probably is this:
"
Michel Dänzer:
Nobody has actively worked on EXA for years.
"

https://bugs.freedesktop.org/show_bug.cgi?id=84253
"
[...]
I again unsuccessfully spent several days to try to find a bug in MSEgui, try
to find a workaround or to find a small testapplication which shows the
problems.
MSEgui paints on a pixmap with the size of the update region which is moved to
the window by xcopyarea() after the drawing is complete.
The attached application draws a diagonal line over a grid cell. Every 2
seconds the cell will be invalidated and refreshed. At startup the display is
OK, after 2 seconds the diagonal line will be truncated. This has been
reproduced on three installations.
If the test-program is started with any command line parameter
(ex. "./radeonline abc" the drawing of the blue rectangle is disabled. Two of
the three installations always show the diagonal line in this mode with full
length, one truncates it after 2 seconds.
With the option "EXAPixmaps" "off" in xorg.conf all is OK.
The simplified testprogram from
https://bugs.freedesktop.org/show_bug.cgi?id=69543
shows a distorted display also by directly drawing to the window so the double
buffering probably is not the culprit.

 Michel Dänzer 2014-09-24 02:41:18 UTC

Probably an EXA issue. Option "EXAPixmaps" "off" mostly avoids the hardware
acceleration paths in EXA.

Comment 2 Martin Schreiber 2014-09-24 05:47:09 UTC

Who is responsible for "Server/Acceleration/EXA"?

Comment 3 Michel Dänzer 2014-09-24 06:14:08 UTC

Nobody has actively worked on EXA for years. <<<---!!!

Comment 4 Martin Schreiber 2014-09-24 06:36:36 UTC

What to do now? What do you recommend?
"
Silence...

Martin


_______________________________________________
mseide-msegui-talk mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mseide-msegui-talk